Jump to content
Sign in to follow this  
shael

Mody nie działają SoC GOG

Recommended Posts

Witam. Jak w temacie, wrzucam gamedatę do folderu z grą, edytuję plik fsgame.ltx i gra się wysypuje. Nie działa ŻADEN mod, nawet ten na udźwig. O co chodzi? 

Share this post


Link to post
Share on other sites

@shael a zobacz na jakiej wersji jest ten stalker pewnie 1.0006 no i czy masz wersję polską z napisami i z lektorem M.Uttą. Czy też to jest wersja "europejska", angielska. Czy tam sobie samemu możemy zmieniać wersję dowolnie czy trzeba pobierać od nowa bo to może być problem.

 

Share this post


Link to post
Share on other sites

No i to może być problem, że to wersja angielska? Kiedyś tam nie było polskiej ale teraz niby w opisie jest, że jest i ma zarówno napisy polskie i dźwięki.

A wejdź sobie na konto i spróbuj pobrać instalator i wybierz polską wersję i ewentualnie zainstaluj. No i jak gra w wersji 1.0006 to na niej uruchomisz mody zrobione pod nią, a niestety najwięcej jest na wersję 1.0004.

I teraz byś musiał sobie poczytać o czymś takim jak downgrade patcha, czy u nas czy w necie. Od razu mówię, że nie wiem czy da się to robić na wersji z GoG bo już też szukałem info po necie ale nie bardzo konkrety jakieś znalazłem.

Ewentualnie możesz poszukać w googlu "stalker soc gog version how instal mods" itp czy też po polsku.

Share this post


Link to post
Share on other sites
22 godziny temu, portals napisał:

Czyli czego? Próbowałeś pobrać polską wersję? Jakie mody nie działają? Ja nie mam problemów z GOGową wersją.

Zmiany wszelakich parametrów w fsgame, uprawnień itd. Mod na udźwig, Gnomus Scopes v2 ani Stalker Complete nie działają. Niby wszystko okej, ale nie działa :/. Polskiej wersji nie znalazłem nigdzie.

Share this post


Link to post
Share on other sites

@shael Przy instalacji jest do wyboru polski język. Jeśli nie ma, obok przy Zainstaluj jest taki "przycisk". Naciśnij, potem przejdź do Zarządzaj instalacją, następnie Konfiguruj i zakładkę Instalacja i tam będzie do wyboru język.

Share this post


Link to post
Share on other sites

@Protean A to chyba, że tak. To możesz mieć rację. Ja też zawsze pobieram instalatory, z GoG Galaxy nie korzystam.

Ale nawet pomimo tego powinien mieć jakiś sposób do zmiany języka jak pisałem wyżej. No chyba, że pobrał i zainstalował grę dawno temu albo pobrał instalator z grą po angielsku.

Share this post


Link to post
Share on other sites

@Protean  Jest jeszcze jedna możliwość zaradzenia problemowi. Na forum są repacki gier od kiedyś @Koma, a teraz  ma inną ksywkę, @Pirunvirsi. W tych paczkach są gry rozbite na czynniki pierwsze. Ostatnio ktoś na nowo dał odświeżone inki do nich. Są też kompletne spolszczenia. Wydaję mi się że wsadzenie takiego spolszczenia do Twojej angielskiej wersji, powinno dać wersję polską, kompletną. A znajdujący się w polonizacji moda plik localization, pokaże grze jakiego liternictwa używać. Bez niego podmiana plików tekstowych, powoduje brak znaków diaktrycznych. Tak samo bywa, jak spolszczenie bez odpowiedniego localization, nakłada się na rosyjski podkład.

Share this post


Link to post
Share on other sites

Ja bym tam prędzej posprawdzał logi z gry i zobaczył czy w logach nie wyskakuje jakiś błąd czy nie brakuje jakichś plików.

Kiedyś miałem podobny problem, że np. Complete nie chciał mi się wczytywać. Potem wyszło na to, że brakowało jakiegoś pliku tekstowego.

Edited by Pirunvirsi
ortografia

Share this post


Link to post
Share on other sites

@Pirunvirsi  @Protean

Jeśli po wstawieniu do katalogu text, katalogu pol, są polskie dialogi be znaków diakrytycznych, to najprawdopodobniej albo brakuje pliku localization, albo jeśli jest, to jest niewłaściwie zbudowana linia językowa lub znaków.

Powinna wyglądać tak:

[string_table]
language    = pol
font_prefix    = _cent ;_west

Jeśli przed _cent ;_west jest średnik ";" należy go usunąć.

Ale też dobrym rozwiązaniem dla @Protean byłoby zrobienia sobie z tych repacków "polskiej podstawki". Tym bardziej, że od razu będzie ją miał w v. 1.0004, przez co uniknie konieczności degradacji i związanych z tym problemów. A roboty przy podstawce mniej, niż przy tych kombinowaniach z przerabianiem angielskiej. A w razie potrzeby mieć v.1.0006, doklei patche i gotowe.

Nie pamiętam gdzie jest ten nowy link do repacków. @Pirunvirsi  możesz mu go wskazać?

Share this post


Link to post
Share on other sites

Mam gdzieś grę na płycie, oryginał, ale zanim go znajdę to mi się cierpliwość skończy i rzucę Cień Czarnobyla w cholerę na następnych parę lat ;p.  Z logów wywnioskowałem, że chodzi o:

-FATAL ERROR
 
[error]Expression    : I
[error]Function      : CInifile::Load
[error]File          : E:\stalker\sources\trunk\xrCore\Xr_ini.cpp
[error]Line          : 166
[error]Description   : Can't find include file:
[error]Arguments     : medic.ltx
 

stack trace:

 

ORAZ:

FATAL ERROR
 
[error]Expression    : wave&&wave->length()
[error]Function      : CSoundRender_Source::LoadWave
[error]File          : E:\stalker\sources\trunk\xrSound\SoundRender_Source_loader.cpp
[error]Line          : 65
[error]Description   : Can't open wave file:
[error]Arguments     : d:\gry\s.t.a.l.k.e.r. shadow of chernobyl\gamedata\sounds\weapons\t_g36_shot.ogg
 

stack trace:

 

Co jest dziwne, bo to mody tylko na udźwig i celowniki

Share this post


Link to post
Share on other sites

@shael  Takie błędy występują, jak jest nieodpowiednia lista plików do wczytania w localization.ltx. ten plik zawsze ma ją zrobioną dla podstawki, dla jakiej jest spolszczenie.

Pisałem powyżej, że jeśli pliki dla zwiększenia udźwigu są z innego moda, to zmiany w nich mogą nie współgrać z tą grą do której się je wstawia.

Jak nie chcesz szukać tego co masz gdzieś w szufladzie czy na półce, to pobierz repacki od Pirunvirsi i zrób sobie polską grę. Będziesz miał jak znalazł do stawiania modów.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.

Discord
Comunity