Skocz do zawartości
Кристофер (Kpuc)

Degradacja patcha - SoC 1.000 ; 1.0003 ; 1.0004 ; 1.0005 + fsgame.ltx + gamedata + Out off Memory

Rekomendowane odpowiedzi

Postanowiłem stworzyć najprostszy do bólu sposób zmiany wersji gry.

Plusem tych paczek jest możliwość zmiany wersji gry jak rękawiczek, nawet dla osoby mającej premierowe wydanie.

Sposób dla patcha 1.0004, pliki czytaj w każdej paczce.

Info.

Jest to paczka na degradacje gry(PL) do niższej wersji, tak by można było grać z modami nieprzystosowanymi do ostatniej wersji patcha 1.0006.

Sporo osób posiada problem z ostatnim wydaniem sklepowym i wersją dodana do CDA

Zmieniona została także linijka w fsgame.ltx i dodany katalog gamedata dla modów.

Gra ma już stworzony folder gamedata, każdy mod który pobieramy na ogół jest właśnie w takim folderze. Ważne by nie zrobić kaszanki, pliki powinno się skopiować/przenieść do katalogu gamedata. Mówiąc łopatologicznie nie tworzymy gamadata/gamedata

Dołączona grafika

Instalacja:

po zainstalowaniu gry z wyżej wymienionych źródeł, skasuj wszystkie pliki i folder bin oprócz plików poniżej:

gamedata.db0

gamedata.db1

gamedata.db2

gamedata.db3

gamedata.db4

gamedata.db5

gamedata.db6

gamedata.db7

gamedata.db8

gamedata.db9

gamedata.dba

następnie wypakuj moją paczkę i przenieś pliki z katalogu S.T.A.L.K.E.R. - Shadow of Chernobyl PLIKI do swojego katalogu z zainstalowana grą. Od tej chwili posiadasz grę w wersji 1.0004

Jest jeszcze jeden problem, musisz podmienić plik exe z paczki na zwiększoną pamięć dla aplikacji z 2 do 3GB, w przeciwnym razie większość modów będzie się zawieszać z błędem ''Out Off Memory''

Patch dla wszystkich wersji SoC:...http://www.stalkerte...-out-of-memory/

Ważne...

.. nie dołączam wpisów rejestru, są do niczego nie potrzebne. W paczce znajdują się oryginalne pliki, nie jest to też cała gra a wiec nie jest to piractwo. W paczce NIE znajdują się żadne cracki i tym podobne.

Pozdro Kpuc

Odświeżony link: https://skydrive.liv...9A35E254D1A!141

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Każdy potrafi czytać ze zrozumieniem. Dodałbym tylko wytuszowanie zdania o załączonym folderze gamedata i potrzebie przeniesienia samych plików z folderu gamedata modów. Plus Kpuc.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ten patch jest potrzebny ze względu na brak posiadania płyty z grą gdy mamy grę w wydaniu CDA lub Gold. Instalujemy go obowiązkowo bez względy na posiadany system. A przy 64Bitowym systemie tym bardziej, patch jest uniwersalny i działa prawie z każdym modem. Nie dział na pewno z NS.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Co najlepiej używać na te 3GB, pliki exe od Depy czy program zawarty w temacie żelażnych zasad wydajności a może patch?

Tak chodzi właśnie o ten patch od Depy :), link już został zaktualizowany w pierwszym poście.

Duży błąd to dodanie katalogu gamedata..będą wieczne problemy jak przy LWR...każdy mod ma swój gamedata, a przy przenoszeniu zawartości samego folderu łatwo coś zgubić.. :)''

To zależny, ja się spotkałem nieraz z wolnymi plikami. Ktoś zarchiwizował je w folderze gamedata.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Niestety, jest jeden mały problem, a mianowicie - od niedawna nie można ściągąć żadnych plików poza własnymi z wupload, ergo przydałoby się wrzucić paczki na inny serwis.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Witaj madry, mam wlasnie stalkera z cda , robie tak jak w opisie, niestety u mnie to nie dziala, nadal mam po tej operacji i restarcie kompa gre na patchu 1.0006 . Widac na liscie programow a takze podczas instalowania patcha 1.0005 wiadomosc o zainstalowanej juz wersji 1.0006. Win 7 64 bit dla scislosci. Gra chodzi normalnie, no jak na stalkera po za paroma wypadami na pulpit. Mam jeszcze jedno pytanie. Poniewaz posiadam ta gre w tez wersji 1.0001, tyle ze niemieckiej czy po instalacji i podmianie twoich plikow bede mial wersje pl? a jezeli nie to czy jest jakas mozliwosc podmiany plikow z plyty cda np. i ktorych?

Edytowane przez dowcipo

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Witaj madry, mam wlasnie stalkera z cda , robie tak jak w opisie, niestety u mnie to nie dziala, nadal mam po tej operacji i restarcie kompa gre na patchu 1.0006 . Widac na liscie programow a takze podczas instalowania patcha 1.0005 wiadomosc o zainstalowanej juz wersji 1.0006. Win 7 64 bit dla scislosci.

Wyraźnie napisane jest że nie daje wpisów rejestru, nie są do niczego potrzebne bo po jakiego wafla instalujesz na spreparowana grę patcha ??? Jak chcesz zrobić samobója to wejdź w rejestr zmień wpis i zainstaluj patch, co z tego wyjdzie?!

Masz grę w wersji 1.0006 potrzebujesz 1.0004 > pobierasz paczkę 1.0004 i postępujesz zgodnie z instrukcją.

Mam jeszcze jedno pytanie. Poniewaz posiadam ta gre w tez wersji 1.0001, tyle ze niemieckiej czy po instalacji i podmianie twoich plikow bede mial wersje pl? a jezeli nie to czy jest jakas mozliwosc podmiany plikow z plyty cda np. i ktorych?

To są paczki do wersji PL, prawdopodobnie trzeba będzie zmienić wpis w pliku lokalization.ltx i dodać brakujące pliki jerzykowe.

Postępuj według instrukcji napisanej tu na forum, te w paczkach są stare. A z powodu mojego słabego łącza nie będę ich uploadował jeszcze raz.

Ewentualne problemy, pisz w temacie.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jak dobrze zakumałem, to wystarczy mi pobrać 10004 z tego linka i po wyrzuceniu wszystkiego z wersji 10006, oprócz gamedat, wkleić to co się pobierze. Jeśli tak, to chyba najprostsza robota, aby zdegradować "szóstkę". :biggrin:

A powrót do "szóstki", jest odwrotnie wprost proporcjonalny do poprzednio wykonanego działania.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

@Kris, ten Twój sposób jest genialny, bez wysiłku i gdybania "czy dobrze zrobiłem", zdegradowałem wersję "szóstki" do "czwórki". Zrobiłem kopię tego, co wywaliłem do osobnego folderu i jak zajdzie potrzeba, to mam jak na talerzu, garść plików na zrobienie "szóstki". Dzięki Ci za taki fajny pomysł. Innych pomysły też są ciekawe, ale wybrałem Twój, @Kris, bo napisałeś, że robi się to prosto i bez żadnych ceregieli.

Edytowane przez metek58

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ja, aby przy kolejnych modach nie kombinować z odtwarzaniem podstawki, zrobiłem tak.

Skopiowałm całą grę do nowego katalogu, o nazwie innej niż dla gry. Tą kopię zdegradowałem do 1.004 i podmieniłem fsgame.ltx na ten od trurl3 ( zapisy są robione w katalogu spaczowanej wersji). Od silnika zrobiłem skrót na pulpit. Mam więc dwie wersje tej samej gry i zapisy się nie nakładają. Ich nie używam do grania, chyba że 1.006 w czysta grę.

Chcąc grać w moda, zależnie od tego jakiej podstawki potrzebuje, znów robię jej kopię do nowego katalogu z nazwą moda. W razie 1.006 zmieniam - po zmodowaniu - fsgame.ltx i skrót do silnika.

Fakt, że zajmuje to sporo miejsca na dysku, ale nie mam najmniejszych konfliktów, bo te kopie nie ingerują w siebie i rejestr.

Przy usuwaniu moda, usuwam skrót, a następnie katalog z modem i nie pozostaje po nim żaden ślad. Dodatkowo, na wszelkiwypadek miotła. Dziury w dysku usuwam, defragmentując go.

Nowy mod, nowa kopia i modowanie - na na pewno czystą podstawkę. Gdy wystąpią problemy - bezbolesne usunięcie moda.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

@kondotier, tak robiłem kiedyś, miałem swego czasu koło 20 modów naraz, zajęte było dobre 120GB samymi stalkerami. Teraz nie mam już tyle czasu na granie i sam stalker mi się znudził. Ostatnio jedyna gra która mnie zassała jak kiedyś stlker to był FarCry3 ;)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

@Kpuc - ale przychodzą nowi STALKERzy, nawet 12 latkowie. Dla nich takie porady, to o połowę mniej pytań typu "co źle zrobiłem" . A oni szybko ze Stalkerów nie zrezygnują. I z modów też.

Można do wszystkiego dojść samemu, ale po co wyważać otwarte drzwi.

Jednak się cieszę, że ( sam do tego doszedłem ) ten sposób jest dobry i inni też z niego korzystali. A korzystam z niego, ze względu na łatwość usunięcia moda już zaliczonego, albo takiego, który już po paru chwilach mi nie odpowiada. Krótko bawię się w mody, ale już takie miałem. I z podstawką problemu nie ma.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Kpuc - czy możesz się do tego ustosunkować?

Tytuł tematu sugeruje, że v 1.0006 można przy pomocy "paczki" zmienić na dowolną aż do v 1.0000. Ale jest tam też coś takiego :

 

 

Od tej chwili posiadasz grę w wersji 1.0004

 

A jak osiągnąć v 1.0005? Kolejno dokładając patcha podnoszącego wersję?

Nadmieniam, że paczki nie pobierałem, więc nie znam zawartości.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

×

Powiadomienie o plikach cookie

Używają strony akceptujesz regulamin Warunki użytkowania.

Społeczność
Discord