Jump to content

Zadanie na Zdjęcie monolitu wylot po odnalezieniu teleportu


Recommended Posts

WItam

 

Po rozwiązaniu problemu zawieszania gry na Generatorach, kolejny bug w Sarkofagu po odnalezieniu teleportu w kwescie na zrobienie zdjęcia Molonitu.

 

error]Expression : !lst.empty()
[error]Function : CHudItem::animGet
[error]File : E:stalkerpatch_1_0004xr_3daxrGameHudItem.cpp
[error]Line : 295
[error]Description : svd_idle

 

Wynika to z tego, że po zbliżeniu do teleportu zalicza nam się zadanie na odnalezienie tegoż teleportu i spawnuje się fotobroń i to ona generuje problem (a w zasadzie jej animacja, choć to dziwne bo w tym momencie nie trzymamy jej nawet w rękach).

 

ROZWIĄZANIE

Otwieramy gamedata/config/misc/arhara_items wyszukujemy fragment kodu (nas dotyczy zielony):

 

[wpn_svd_foto_hud]

shell_point      = -0.140000,-0.030000,0.080000
shell_dir        = 0.0, 1.0, 0.0

fire_point      = 0.200000,-0.070000,0.090000
fire_bone = wpn_body
orientation = -0.049999,0.750000,1.550001
position   = -0.063500,-0.150999,0.049000
visual   = weaponssvdwpn_svd_hud.ogf

anim_holster  = svd_holster
anim_idle  = svd_idle
anim_idle_aim  = svd_idle_aim
anim_reload    = svd_reload
anim_draw  = svd_draw
anim_holster  = svd_holster
anim_shoot  = svd_shoot

 

I teraz po usunięciu przedrostków 'svd_' wylot zmienil opis na [error]Description : idle_aim. Więc chyba coś miałem pomieszane w plikach gry postanowiłem wieć zastąpić animacje animacja pustą (schowana broń - holser) i pomogło. Ostatecznie moj plik arhara_items.ltx wygląda tak:

 

anim_holster  = holster
anim_idle  = holster
anim_idle_aim  = holster
anim_reload    = reload
anim_draw  = draw
anim_holster  = holster
anim_shoot  = shoot

 

Gry nie wywala a mając w ręku Fotobroń nie ma ona animacji, nacelowyjemy przy użyciu krzyżyka widocznego na ekranie w trybie celowania (aim) widać celownik optyczny, brakuje animacji podnoszenia broni do celowania przez celownik oraz animacji samej broni trzymanej w rękach. Biorąc pod uwagę, że z broni oddajemy tylko jeden strzał - dla mnie żaden problem! :D

Mam nadzieje że komuś to pomoże, bo również spędziłem na tym trochę czasu. Z tego co czytałem u jednych pomaga dodanie svd_ u innych działa bez _svd. U mnie zadziałało tak jak opisałem.

Edited by Taran
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.