Jump to content
Hrothgar

Crash po zainstalowaniu spolszczenia.

Recommended Posts

Okej zrobiłem jak trzeba, zainstalowałem w podanej kolejności: Grę patch 2.10 i spolszczenie i zauważyłem kilka rzeczy:

- gra podaje po dodaniu spolszczenia wersję 2.09 (mimo zainstalowania spolszczenia niby do 2.10)

- link do spolszczenia na ST nie istnieje albo zdechł

- gra po włożeniu spolszczenia zdycha z fatal errorem.

 

Po nałożeniu patcha 2.10 po tej sytuacji gra odpala z napisem 2.10. Spolszczenie coś miesza.

Share this post


Link to post
Share on other sites

Spolszczenie w v2.10 nie ma zaktualizowanego jednego wpisu i dlatego w menu masz 2.09 (chociaż naprawdę jest to wersja 2.10) możesz sobie samemu to zmienić o ile pamietam było o tym w temacie albo w gorszej wersji na sb ;) to sobie nie zmienisz jak ci ktoś nie powie, w którym to było pliku.

Także ono nic nie miesza, jest dobre.

O padniętym linku była mowa na sb ale widać żaden moderator/admin nie zauważył. Trzeba zgłosić na PW.

Zdychanie z fatall errorem to nam nic nie mówi bez podania loga, tak to możesz napisać do wróżbity Macieja.

 

Edited by tom3kb

Share this post


Link to post
Share on other sites

Może grzeczniej, mówcie tak do kogoś kto wam na to pozwala.

 

* Detected CPU: GenuineIntel Pentium-III, F6/M7/S10, 3007.00 mhz, 32-clk 'rdtsc'
* CPU Features: RDTSC, MMX, SSE, SSE2

Initializing File System...
using fs-ltx fsgame.ltx
FS: 45992 files cached, 5921Kb memory used.
Init FileSystem 0.834703 sec
'xrCore' build 3312, Feb 27 2008

Initializing Engine...
Starting INPUT device...
Loading DLL: xrRender_R2.dll
using OGSE.DLL rev.64 build Mar 29 2016
Loaded: extensions\ogse.dll
Loading DLL: xrGame.dll
* [win32]: free[4059880 K], reserved[53868 K], committed[80492 K]
* [ D3D ]: textures[0 K]
* [x-ray]: crt heap[10042 K], process heap[737 K], game lua[0 K], engine lua[0 K], render[0 K]
* [x-ray]: economy: strings[4884 K], smem[0 K]
Executing config-script "d:\stalker\gamedata\config\default_controls.ltx"...
! cant convert dik_name for dik[144], prop=[Poprzednia
[d:\stalker\gamedata\config\default_controls.ltx] successfully loaded.
Executing config-script "user.ltx"...
Executing config-script "d:\stalker\gamedata\config\rspec_default.ltx"...
[d:\stalker\gamedata\config\rspec_default.ltx] successfully loaded.
Executing config-script "d:\stalker\gamedata\config\default_controls.ltx"...
[d:\stalker\gamedata\config\default_controls.ltx] successfully loaded.
[d:\stalker\_appdata_\user.ltx] successfully loaded.
SOUND: OpenAL: enumerate devices...
SOUND: OpenAL: EnumerationExtension Present
devices Generic Hardware
SOUND: OpenAL: system  default SndDevice name is Generic Hardware
SOUND: OpenAL: default SndDevice name set to Generic Software
SOUND: OpenAL: All available devices:
1. Generic Software, Spec Version 1.1 (default)
2. Generic Software, Spec Version 1.1 (default)
SOUND: OpenAL: SelectBestDevice is Generic Software 1.1
SOUND: OpenAL: Required device: Generic Software. Created device: Generic Software.
* sound: EAX 2.0 extension: absent
* sound: EAX 2.0 deferred: absent
* sound : cache: 32773 kb, 3805 lines, 8820 bpl
Starting RENDER device...
Loaded: extensions\ogse.dll
* GPU [vendor:1002]-[device:9442]: ATI Radeon HD 4800 Series
* GPU driver: 8.17.10.1129
* CREATE: DeviceREF: 1
* Vertex Processor: PURE HARDWARE
*     Texture memory: 2287 M
*          DDI-level: 9.0
* GPU shading: vs(fffe0300/3.0/30), ps(ffff0300/3.0/30)
* GPU vertex cache: unrecognized, 16
* DVB created: 6144K
* DIB created: 512K
! Version conflict in shader 'def_shaders\def_aref'
! Version conflict in shader 'def_shaders\def_aref_noblend'
! Version conflict in shader 'def_shaders\def_aref_v'
! Version conflict in shader 'def_shaders\def_trans'
! Version conflict in shader 'def_shaders\def_trans_v'
! Version conflict in shader 'def_shaders\def_trans_v_tuchi'
! Version conflict in shader 'def_shaders\def_vertex'
! Version conflict in shader 'def_shaders\lod_old'
! Version conflict in shader 'default'
! Version conflict in shader 'effects\lightplanes'
! Renderer doesn't support blender 'effects\shadow_world'
! Version conflict in shader 'effects\watertest-1'
! Version conflict in shader 'selflight'
! Version conflict in shader 'selflight_static'
count of .thm files=1039
load time=70 ms
* NULLRT supported
* ...and used
* HWDST/PCF supported and used
Shadow Map resolution: 2048x2048
OS VERSION: VISTA OR ABOVE
- r__tf_aniso 4
- r2_tf_mipbias 0.
--SetLogCallback to file d:\stalker\_appdata_\logs\_ogse.log
Loaded: extensions\ogse.dll
file: .
file: ..
file: LuaXML_lib.dll
--try to load LuaXML_lib.dll
fname: LuaXML_lib
~~    loaded
file: ogse.dll
--try to load ogse.dll
fname: ogse
open_global_ns - start
open_global_ns - end
~~    loaded
file: ogse.pdb
file: xp
~~        _G : os.clock() = 6.3449997901917    math.randomseed()
luaxml1
luaxml2
!!OGSE_vers = Final_2.10(22/05/2016)**
!!INFO: LuaXML library loading successful.
Starting engine...
Loading DLL: xrGameSpy.dll
[INTEGRITY CHECK] books
[INTEGRITY CHECK] creatures
[INTEGRITY CHECK] game_maps_single.mus
[INTEGRITY CHECK] localization.ltx
[INTEGRITY CHECK] misc
[INTEGRITY CHECK] mp
[INTEGRITY CHECK] text
[INTEGRITY CHECK] tuning
[INTEGRITY CHECK] ui
[INTEGRITY CHECK] weapons
[INTEGRITY CHECK] gulag_garbage.script
[INTEGRITY CHECK] news_data.script
[INTEGRITY CHECK] news_main_data.script
[INTEGRITY CHECK] news_main_new.script
[INTEGRITY CHECK] news_main_spawn.script
[INTEGRITY CHECK] ogse_car_trade.script
[INTEGRITY CHECK] tasks_functor.script
[INTEGRITY CHECK] ui_yan_random_quest_wnd.script
[INTEGRITY CHECK] xr_companion.script
[INTEGRITY CHECK] _change_list.script
[INTEGRITY CHECK] GAME ARCHIVES EXISTS
* DVB created: 6144K
* DIB created: 512K
- r__tf_aniso 4
- r2_tf_mipbias 0.
* GPU shading: vs(fffe0300/3.0/30), ps(ffff0300/3.0/30)
* GPU vertex cache: unrecognized, 16
*** RESET [284 ms]
"d:\stalker\bin\xr_3da.exe"
* phase time: 0 ms
* phase cmem: 94613 K

Loading objects...
Loading models...
* [prefetch] time:    1735 ms
* [prefetch] memory:  0Kb
* phase time: 1744 ms
* phase cmem: 74000 K
[S.]
--SetLogCallback to file d:\stalker\_appdata_\logs\_ogse.log
Loaded: extensions\ogse.dll
file: .
file: ..
file: LuaXML_lib.dll
--try to load LuaXML_lib.dll
fname: LuaXML_lib
~~    loaded
file: ogse.dll
--try to load ogse.dll
fname: ogse
open_global_ns - start
open_global_ns - end
~~    loaded
file: ogse.pdb
file: xp
~~        _G : os.clock() = 19.704999923706    math.randomseed()
luaxml1
luaxml2
!!OGSE_vers = Final_2.10(22/05/2016)**
!!INFO: LuaXML library loading successful.
! Cannot find saved game ~~~ sandbox initialized
* Log file has been saved successfully!
* phase time: 76 ms
* phase cmem: 74207 K
[S.T.]
* phase time: 1 ms
* phase cmem: 74207 K
[S.T.A.L.K.]
* Creating new game...
* Loading spawn registry...
* 11631 spawn points are successfully loaded
* Saving spawns...
* Saving objects...
Đŕçěĺđ íĺňďŕęĺňŕ Ńčäîđîâč÷ŕ 245
* Log file has been saved successfully!
* 27648 objects are successfully saved
* Game all.sav is successfully saved to file 'd:\stalker\_appdata_\savedgames\all.sav'
* New game is successfully created!
* phase time: 6696 ms
* phase cmem: 136292 K
[S.T.A.L.K.]
MaxPlayers = 32
Đŕçěĺđ íĺňďŕęĺňŕ Ńčäîđîâč÷ŕ 245
* Log file has been saved successfully!
* phase time: 352 ms
* phase cmem: 136325 K
[S.T.A.L.K.]
# Player not found. New player created.
* client : connection accepted - <>
* phase time: 11 ms
* phase cmem: 136349 K
[S.T.A.L.K.]
* phase time: 10 ms
* phase cmem: 136349 K
[S.T.A.L.K.]
* phase time: 3621 ms
* phase cmem: 211966 K
[S.T.A.L.K.E.R.]
* phase time: 1455 ms
* phase cmem: 213889 K
[S.T.A.L.K.E.R.]
* [Loading VB] 65535 verts, 2047 Kb
* [Loading VB] 65533 verts, 2047 Kb
* [Loading VB] 65125 verts, 2035 Kb
* [Loading VB] 15983 verts, 499 Kb
* [Loading VB] 65533 verts, 2047 Kb
* [Loading VB] 65534 verts, 2047 Kb
* [Loading VB] 65530 verts, 2047 Kb
* [Loading VB] 65532 verts, 2047 Kb
* [Loading VB] 65534 verts, 2047 Kb
* [Loading VB] 65535 verts, 2047 Kb
* [Loading VB] 65533 verts, 2047 Kb
* [Loading VB] 65534 verts, 2047 Kb
* [Loading VB] 65534 verts, 2047 Kb
* [Loading VB] 35490 verts, 1109 Kb
* [Loading VB] 65533 verts, 2047 Kb
* [Loading VB] 65535 verts, 2047 Kb
* [Loading VB] 65533 verts, 2047 Kb
* [Loading VB] 65534 verts, 2047 Kb
* [Loading VB] 65535 verts, 2047 Kb
* [Loading VB] 65535 verts, 2047 Kb
* [Loading VB] 65535 verts, 2047 Kb
* [Loading VB] 50690 verts, 1584 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 1029864 indices, 2011 Kb
* [Loading VB] 65535 verts, 767 Kb
* [Loading VB] 65533 verts, 767 Kb
* [Loading VB] 65534 verts, 767 Kb
* [Loading VB] 65535 verts, 767 Kb
* [Loading VB] 65535 verts, 767 Kb
* [Loading VB] 65535 verts, 767 Kb
* [Loading VB] 65535 verts, 767 Kb
* [Loading VB] 65535 verts, 767 Kb
* [Loading VB] 65533 verts, 767 Kb
* [Loading VB] 65102 verts, 762 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 1048575 indices, 2047 Kb
* [Loading IB] 798990 indices, 1560 Kb
* phase time: 1142 ms
* phase cmem: 214149 K
[S.T.A.L.K.E.R.]
* phase time: 1320 ms
* phase cmem: 220185 K
[S.T.A.L.K.E.R. O]
* [DETAILS] VertexConsts(256), Batch(80)
* [DETAILS] 53360 v(20), 34560 p
* [DETAILS] Batch(80), VB(1042K), IB(202K)
* phase time: 237 ms
* phase cmem: 220260 K
[S.T.A.L.K.E.R. O]
* Loading HOM: d:\stalker\gamedata\levels\l01_escape\level.hom
* phase time: 49 ms
* phase cmem: 220418 K
[S.T.A.L.K.E.R.–O O]
* phase time: 64 ms
* phase cmem: 220687 K
[S.T.A.L.K.E.R. O G]
Đŕçěĺđ íĺňďŕęĺňŕ Ńčäîđîâč÷ŕ 245
* Log file has been saved successfully!
- Game configuring : Started
- Game configuring : Finished
* phase time: 240 ms
* phase cmem: 232091 K
[S.T.A.L.K.E.R. O G S]
!! cannot load texture 'wpn\wpn_ak74'
!! cannot load texture 'wpn\wpn_aksu'
!! cannot load texture 'wpn\wpn_svd'
* t-report - base: 1348, 698615 K
* t-report - lmap: 8, 8193 K
* phase time: 3237 ms
* phase cmem: 232091 K
[S.T.A.L.K.E.R. O G S E]
* phase time: 26 ms
* phase cmem: 232091 K
* [win32]: free[2713184 K], reserved[104092 K], committed[1376964 K]
* [ D3D ]: textures[706808 K]
* [x-ray]: crt heap[232091 K], process heap[7239 K], game lua[69260 K], engine lua[315 K], render[0 K]
* [x-ray]: economy: strings[7488 K], smem[0 K]
Loaded: extensions\ogse.dll
file: .
file: ..
file: LuaXML_lib.dll
--try to load LuaXML_lib.dll
fname: LuaXML_lib
~~    loaded
file: ogse.dll
--try to load ogse.dll
fname: ogse
~~    loaded
file: ogse.pdb
file: xp
! Invalid ogg-comment version, file:  d:\stalker\gamedata\sounds\characters_voice\scenario\superkontroler\avaaa.ogg
! Invalid ogg-comment version, file:  d:\stalker\gamedata\sounds\characters_voice\scenario\superkontroler\fooooood.ogg
 
FATAL ERROR
 
[error]Expression    : fatal error
[error]Function      : CInifile::r_string
[error]File          : E:\stalker\sources\trunk\xrCore\Xr_ini.cpp
[error]Line          : 352
[error]Description   : <no expression>
[error]Arguments     : Can't find variable ammunition_on_belt in [options]
 

stack trace:

 

Share this post


Link to post
Share on other sites

@Hrothgar

Miałem ten sam error i nic nie mogłem z nim zrobić po tym jak miałem moda zainstalowanego w tej kolejności.

OGSE 2.0 final

Patch 2.09

Spolszczenie.2.09 (oczywiście dodatek na więcej slotów na pasie).

Potem wyszedł patch 2.10 i spolszczenie do niego wraz z fixem na sloty na pasie.

Zainstalowałem je bo niby miało się dać grać na sejwach z wersji 2.09. Niestety przy każdej próbie wczytania sejwa robionego na 2.09 grę wywalało z takim logiem.

Nawet próbowaliśmy odpalać moje sejwy u innych i nic to nie dało.

Chyba parę osób grało normalnie na wersji 2.10 na starych sejwach z 2.09 i poszli spokojnie dalej ale u mnie się nie dało.

Więc jako, że byłem już dość daleko w fabule gram wciąż na wersji 2.09.

 

Także moje pytanie jest takie czy czasem nie próbujesz odpalać sejwów ze starszej wersji na OGSE 2.10?

 

Edited by tom3kb

Share this post


Link to post
Share on other sites

A nie wrzucałeś po spolszczeniu czasem fixa na więcej slotów w pasie czasem tego rosyjskiego? Tak już kombinuję.

Edited by tom3kb

Share this post


Link to post
Share on other sites

Wywal wszystko do kosza, wyczyść kompa ze śmieci, defrag dysku i rejestru. Postaw na nowo moda zgodnie z opisem i ma działać. To doskonale zoptymalizowany, stabilny mod z którym nie ma większych problemów ani instalacyjnych, ani żadnych innych.

Share this post


Link to post
Share on other sites

Również poruszę temat spolszczenia tylko z innej strony. Z pobieralni ST nie działa. Przy pozostałych dwóch linkach, 360 Security informuje o Trojanach i w związku z tym nie mogę ściągnąć. Teraz pobieram całość z Mega i zobaczymy.   

Share this post


Link to post
Share on other sites

@DaarMoo niektóre antywirusy są przeczulone na punkcie plików .exe właśnie - pokazują że są w nich różnego rodzaju wirusy (co w większości przypadków nie jest zgodne z prawdą).

Możesz śmiało pobierać te spolszczenie (z MEGA), nie ma w nim żadnych wirusów (przeskanowałem swoim Bitdefenderem).

Share this post


Link to post
Share on other sites

Dzięki Allen i Anton !

Tylko, że 360 jak namierzy taki plik to od razu go wywala. Nic to. Ściągnąłem full z Mega i zobaczymy.  

Jedno pytanie. Konfigurator. Używać czy nie ?

Edited by DaarMoo

Share this post


Link to post
Share on other sites

Teoretycznie nie musisz używać konfiguratora, możesz odpalić grę bezpośrednio z pliku XR_3DA.exe w katalogu bin. Nie będziesz mógł tylko ustawić takich opcji moda jak maksymalny udźwig, godzinę rozpoczęcia gry, zachowanie npc itd. Mod uruchomi się z domyślnymi ustawieniami.

Jeżeli czujesz się na siłach to te opcje moda z konfiguratora, możesz ustawić ręcznie w pliku ogse_config.ltx w katalogu głównym moda.

Share this post


Link to post
Share on other sites

Przy próbie odpalenia mam coś takiego:

Przechwytywanie.PNG

i, choć mod zainstalował c++

Przechwytywanie1.PNG

log jest też ciekawy

* Detected CPU: GenuineIntel Pentium-III, F6/M7/S10, 3001.00 mhz, 32-clk 'rdtsc'
* CPU Features: RDTSC, MMX, SSE, SSE2

Initializing File System...
using fs-ltx fsgame.ltx
FS: 46069 files cached, 6466Kb memory used.
Init FileSystem 1.021295 sec
'xrCore' build 3312, Feb 27 2008

Initializing Engine...
Starting INPUT device...
Loading DLL: xrRender_R2.dll
Failed to load library 'extensions\ogse.dll'
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
##called from function 'void __thiscall xrDebug::my_fail(const char *,const char *,int,const char *,bool &)' in file '_main.cpp' on line 141
...Failed - incompatible hardware.
Loading DLL: xrGame.dll
stack trace:

0023:057786C8 xrGame.dll
 
[error][     259]    : Brak dalszych danych.
 

 

 

Share this post


Link to post
Share on other sites

Spróbuj uruchomić plik exe moda jako administrator, jeśli używasz Win 7. U mnie na prawach zwykłego użytkownika wywalał błąd. Chociaż screeny sugerują raczej braki jakichś bibliotek Visual C++.

Share this post


Link to post
Share on other sites

Plik exe uruchamiam jako admin i jest to samo. Visual C++ zainstalowało się z modem. Wersję Full moda ściągnąłem  z Mega. Instaluję wszystko po kolei. No nie wiem. A i jeszcze. Podczas instalacji mam coś takiego.

Przechwytywanie2.PNG  

Share this post


Link to post
Share on other sites

Zobacz jaką masz ścieżkę do instalacji moda. Przecież instalator próbuje Ci wrzucić wszystko bezpośrednio do katalogu Program Files. Stwórz sobie jakiś katalog dla moda i dopiero tam instaluj.

Share this post


Link to post
Share on other sites

Ja sobie spokój dałem . Sama gra się dobrze zainstalowała: chodziła , etc. Trochę połaziłem , by sprawdzić . Po nałożeniu spolszczenia coś nie grało, gra się nie uruchamiała, z podanym wyżej crashlogiem. Co nie działało, nie wiem. Pokazywalo zamiast obecnej w wersji angielskiej 2.10  w polskiej 2.09.

Share this post


Link to post
Share on other sites

Wiesz, generalnie opinie o instalacji i modzie są niezłe. Więc postanowiłem. A że coś się miesza to się miesza. Nie pierwszy raz. Popróbuję. Może coś wyjdzie. Może ktoś podpowie, może. 

Share this post


Link to post
Share on other sites
55 minut temu, DaarMoo napisał:

Przy próbie odpalenia mam coś takiego:

Przechwytywanie.PNG

i, choć mod zainstalował c++

Przechwytywanie1.PNG

log jest też ciekawy

* Detected CPU: GenuineIntel Pentium-III, F6/M7/S10, 3001.00 mhz, 32-clk 'rdtsc'
* CPU Features: RDTSC, MMX, SSE, SSE2

Initializing File System...
using fs-ltx fsgame.ltx
FS: 46069 files cached, 6466Kb memory used.
Init FileSystem 1.021295 sec
'xrCore' build 3312, Feb 27 2008

Initializing Engine...
Starting INPUT device...
Loading DLL: xrRender_R2.dll
Failed to load library 'extensions\ogse.dll'
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
##called from function 'void __thiscall xrDebug::my_fail(const char *,const char *,int,const char *,bool &)' in file '_main.cpp' on line 141
...Failed - incompatible hardware.
Loading DLL: xrGame.dll
stack trace:

0023:057786C8 xrGame.dll
 
[error][     259]    : Brak dalszych danych.
 

 

 

Co do pierwszego obrazka : 

Wersja na 64bity : https://download.dll-files.com/7160fc226391c0b50c85571fa1a546e5/d3dx9_43.zip?0XIlQIbKiP

Wrzucasz do bin to biblioteki DirectXa

Drugi błąd może być spowodowany pierwszym

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.